PPC Not booting from NetBoot Across Subnets package

by on December 29, 2008 » Add more comments.

NetBoot Across Subnets from Mike Bombich has a problem setting the startup disk on a PPC machine when the target is a Leopard NetBoot set. You may see this in your system.log on your NetBoot server:

Dec 29 10:42:08 server tftpd[781]: adding RRQ to cache: 170.140.xxx.xxx,NetBoot/NetBootSP0/DS_MP_2008-12-29.nbi/booter
Dec 29 10:42:08 server tftpd[782]: file not found, trying [/private/tftpboot/NetBoot/NetBootSP0/DS_MP_2008-12-29.nbi/boote]
Dec 29 10:42:08 server tftpd[782]: file not found, trying [/private/tftpboot/NetBoot/NetBootSP0/DS_MP_2008-12-29.nbi/boot]
Dec 29 10:42:08 server tftpd[782]: file not found, trying [/private/tftpboot/NetBoot/NetBootSP0/DS_MP_2008-12-29.nbi/boo]
Dec 29 10:42:08 server tftpd[782]: file not found, trying [/private/tftpboot/NetBoot/NetBootSP0/DS_MP_2008-12-29.nbi/bo]
Dec 29 10:42:08 server tftpd[782]: file not found, trying [/private/tftpboot/NetBoot/NetBootSP0/DS_MP_2008-12-29.nbi/b]

As you can see, it is looking for the booter file at the root of the netboot set. The problem lies in the postflight script within the nbas.pkg package.

To fix the nbas.pkg:

1. Right click (or control+click) the nbas.pkg (or whatever your renamed it to) and “Show Package Contents”

2. Browse to Contents/Resources/ and open the postflight file in your favorite text editor (I prefer vi or TextWrangler)

3. add “ppc” to the following lines as highlighted (including the extra \)

if [ "`arch`" == "ppc" ]; then /usr/sbin/nvram boot-args="rp=${protocol}:${server}:/private/tftpboot/NetBoot/${sharepoint}:${setName}/${imageName}" 
boot-file="enet:${server},NetBoot\${sharepoint}\${setName}\\ppc\\mach.macosx" boot-device="enet:${server},NetBoot\${sharepoint}\${setName}\\ppc\\booter"

4. Save the file

This has been tested on my NetRestore, DeployStudio and SIU NetBoot sets.

Note: I had to edit the file with sudo to prevent a permissions error when I tried to copy the package back up to a server share.

Find more like this: Imaging, Mac, Scripting , , , , , ,


2 Responses to PPC Not booting from NetBoot Across Subnets package

Leave a Reply

Your email address will not be published. Required fields are marked *